Download and installation requires Firefox

Autofill Magic is a Firefox plugin and can not be installed on other browsers.

It seems that you are using a different browser than Firefox.

Please install Firefox and open this page in Firefox. Then you will be able to download and install Autofill Magic.

Get Firefox here